BC Fishing Reports banner

1 - 4 of 4 Posts

·
Registered
Joined
·
816 Posts
Discussion Starter #1
Went fishing in the Harbour today. Started at 09:30ish at the center chanel marker off the Fisheries Station... fished around it for 30min with blood and bone hoochie and flasher at 110' and lime green and silver coyote spoon, nothing. Then tried between the Pink Palace and rock jetty at Ambleside nothing (changed the hoochie to purple hazes). The water was glass but my boat was idoeling to high and I could not troll slow enough... 3.5 knot was as slow as I could go. Tried buzz bombing on stack of bait around Cap, one 5" greenling. Stop at a massive school of bait with seals, commerants, and gull working it right in the middle of English Bay but no salmon. Then troll the 120' line from the last mark at Spanish Bank to just be for Jerico pier... nothing. Stopped at 12:30. One guy at Ambleside said he caught on there earlier in the morning.
There are salmon out there I know it... I feel it... but my boat was going to fast I have to fix it :cry: . (When you gotta put 140' of cable to get to 100' there is a problem.)
Have fun, Jason
 

·
Registered
Joined
·
816 Posts
Discussion Starter #3
Fisho haolick,
first time it has happened... my boats thortal cables are broaken, I need new ones. Got out the WD-40 to make her go in reverse... made the idol go higher. But makes me replace the cables that have been needing since last year... I am a risk taker :wink: . There is not fun if you know your coming back alive.
Have fun, Jason
 
1 - 4 of 4 Posts
Top